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Introduction 

What does RenameMan do? 

RenameMan is a tool that allows you quickly and easily to rename lots of files or folders at 
once. It is an extremely flexible tool, and in particular has special support for handling files 
with a number embedded in the name. 

Features 

• Extremely flexible and easy to use  
• Shows how all the files will be renamed before any are changed on disk  
• Fail safe, any problems (such as trying to rename two files to the same name) are 

prevented  
• Special support for filenames with embedded numbers  
• Automatically finds common parts in filenames  
• Auto number facility makes it easy to create numbered sequences  
• Command store for your most common rename operations  
• Quick access to recent rename commands  
• Undo last rename command  
• Support for using tags from MP3 files  
• Support for using digital photo date/time  

Quick tour of RenameMan 

 
 

The application window is divided into two halves. The left-hand pane contains the folder 
browser, which allows you to select a folder that contains files to be renamed. The right-hand 
pane contains the file list, plus all the controls to rename the files. 

You can adjust the size of the two halves by dragging the bar that separates them. 

The selector is used to configure the rename command by defining what rename boxes are 
shown. These are used to set the rename command.  

The file list shows the old and new names at all times, so you can see exactly how the files 
will be renamed. Pressing the rename button will then rename all the files to the new names 
shown.  
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Getting started 

To rename files using RenameMan involves the following steps.  

1. Select the files to rename 
The files to be renamed need to be added to the file list. There are a number of ways this can 
be done:  

• Using the folder browser (see “The folder browser” on page 5) 
• Using the add files panel (see “Add Files panel” on page 26) 
• By launching RenameMan using the right-click context menu in Windows Explorer 
• Drag & drop from Windows Explorer 

For more information on selecting files to rename, see “Selecting files to rename” below. 

2. Select or set up the rename command 
To use a pre-configured stored command, select it from the stored commands list (see “Stored 
Commands list” on page 13). 

Alternatively, the rename command can be set up manually. The first step is to set the selector 
to select the different parts of the filenames. The selector usually consists of a combination of 
text and wildcard characters (*, ? and #) – see “Pattern matching” on page 7. 

The selector will automatically be set to find text that is common to all the selected filenames, 
so quite often you may not need to change the selector. Otherwise, commonly used selectors 
are:  

* Selects the entire filename 
*.* Selects the filename and extension independently 
*#* Selects filenames containing numbers 
*text* Selects filenames containing text 

 

Once the selector has been set, the different parts of the filenames can be modified 
independently, see “Setting up rename commands” on page 15.  

As a further time-saver, whenever any rename command is used, it is immediately available 
for re-use from the recent commands list – see “Using recent rename commands” on page 25. 

3. Press the Rename button to rename the files 
Finally, press the rename button to rename all the files.  

Note: to revert all the filenames back to what they were, the File>Undo Rename menu 
command can be used.  

Selecting files to rename 

There are a number of ways to add files to the file list for renaming.  

Using the folder browser. 
Clicking on a folder in the folder browser adds all the files in that folder to the file list, 
replacing any files that were already added. Hold down the CTRL key while clicking on the 
folder if you want to keep the files already in the file list.  
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Using the add files panel. 
Use the File>Add Files command to bring up the add files panel. This allows the files added 
to be controlled using filename selection patterns to control filenames to include and those to 
exclude. It also allows files from subfolders to be added.  

By launching RenameMan using the right-click context menu in Windows Explorer. 
Select the files to be renamed in Windows Explorer, and then right click on this selection. 
Select RenameMan from the context menu that pops up, and this will launch RenameMan 
with the selected files already added to the file list.  

Drag & drop from Windows Explorer 
If RenameMan is already running, files can be dragged from Windows Explorer and dropped 
into the file list. The files dragged will be added to those already in the file list.  

Files can be removed from the file list using the File>Exclude command.  

All files can be removed from the file list using the File>Clear List command.  

Selecting folders to rename 

RenameMan can also be used to rename folders. To add folders to the file list, use the 
File>Add Folders command.  

Pattern matching 

Pattern matching is used to find filenames that match a particular pattern. This is done by 
using a combination of text and special “wild” characters. The wild characters can match a 
range of characters in the filenames, and so allow several filenames to be matched at once. 
The wild characters supported are: 

* Matches any character, and any number of characters. 

? Matches any single character. 

# Matches any decimal integer, i.e. any string of adjacent characters which are all in the range 
'0' to '9'. To find the '#' character itself, use the sequence \# 

Examples 
To find all filenames that start with abc, use abc*  

To find all filenames that are exactly four characters long, use ???? 

To find all filenames contain an embedded number, use *#*  

Auto selecting files 

A very common case when renaming lots of files is that you want to change a certain text 
string that all the filenames have in common. For example, all files may start with abc, and 
you may want to change this to xyz. In order to do this, you would need to enter abc* in the 
selector, which would set up a text box in the rename boxes which would allow you to change 
the abc prefix. 

RenameMan helps speed up this common situation by automatically finding the common 
parts of all the filenames whenever the file list changes. For example, if all files do start with 
abc, then the selector will be set to abc*.  
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This auto select function is applied every time the file list changes, unless the rename 
command is locked.  

If only some of the files in the file list have the common parts you want to match, then it is 
best to select some of the files that have the common parts, and then right click the selection 
and use the auto-select command on the context menu. This can be especially useful if you 
want to select files that have the same name except for a changing number, since you only 
need to select one of the files and use the File>Auto Select command (provided the treat 
numbers as text option is off). 

Filenames containing numbers 
RenameMan has special support for filenames containing numbers, so by default the auto-
select function will try to match numbers using the match any number wildcard (#). When this 
is used, number based commands such as adding or removing leading 0s, or adding an offset 
to the number are available.  

However, in some cases where the numbers in the filenames are not important, it may be 
more useful to treat the numbers just like any other characters. This is possible by using the 
File>Treat Numbers As Text command.  

System requirements 

RenameMan works with all versions of Windows later than Windows 98. RenameMan also 
works with Windows 95, provided Internet Explorer 4.0 or later is installed.  

RenameMan will not work on any 16 bit versions of Windows such as Windows 3.1, nor will 
it work on Windows NT 3.51 or earlier.  

RenameMan has been tested on the following:  

• Windows XP  
• Windows Server 2003  
• Windows 2000  
• Windows NT 4.0  
• Windows Me  
• Windows 98  
• Windows 95, with Internet Explorer 5.5 installed.  
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Main windows and controls 

The folder browser 

 

The folder browser provides a simple way to select files for renaming. It works in the same 
way as the folder browser in Windows Explorer. Select a folder by clicking on its name. This 
will automatically add all the files in the selected folder to the file list. Hold down CTRL 
while clicking a folder to add to the files already in the file list, otherwise the file list will be 
cleared before adding the new files. 

To expand a folder to see the subfolders it contains, either click on the + next to the name, or 
double click the name. 

Right click on a folder to bring up the folder browser context menu.  

 
This menu provides the following commands: 

Add Files Brings up the add files panel for the selected folder. 
Add Folders Brings up the add folders panel for the selected folder. 
Explore Opens the selected folder in Windows Explorer. 
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The file list 

 
The file list shows all the files (or folders, if folders have been added using the add folders 
panel) that have been selected for renaming. It shows the existing name in the column titled 
"Old Name", and the new name in the column titled "New Name". 

If there are any files in the file list that are not in the folder that is currently selected in the 
folder browser, then there will also be a "Folder" column. This shows the path to the folder 
containing each file. 

Files that are not matched by the selector are shown grayed out. These files will not be 
renamed if the rename command is selected.  

The column options panel allows extra columns to be added showing the file size, the file last 
modified time and the read-only status. These columns are useful since they allow you to sort 
the file list based on the file size or file last modified time, which can be used to auto-number 
the files based on these attributes. Another way to show or hide these columns is to right click 
in the column header and using the file list column context menu. 

To sort the file list on any column, click in the column header. To reverse the sort order, click 
a second time in the sort column header. The sort column can be identified since it contains a 
small triangle in the header. This points up if the sort order is ascending, or down if the sort 
order is descending. 

To resize the width of the columns, drag the right edge of the header at the top of each 
column. 

Each name may have one of the following symbols next to it to indicate that there is a 
problem with the current rename command. You will not be able to rename the files until all 
these problems are fixed. If you move the mouse over a file with one of these error icons text 
to it, then a tool tip will pop up to show more information about the error. 

 Indicates that the new name is the same name as an existing file.  

 
Indicates that the new name is the same as the new name of one of the 
other files being renamed.  

 
Indicates that the new name is empty. All filenames must have at least one 
character in them.  

 
Indicates that the file does not contain the date/time that the digital photo 
was taken, or that the file is not a digital photo. This error can only occur 
if the digital photo date/time auto-text is being used.  

 
Indicates that the file does not contain a requested MP3 tag, or is not an 
MP3 file. This error can only occur if the MP3 tag auto-text is being used.  
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Right click in the file list to bring up the file list context menu.  

 
This menu provides the following commands: 

Auto Select Runs the auto-selector for the selected files in the file list. 
Exclude Excludes the selected files from the file list. 
Rename Renames the selected files in the file list. Note: This is different to 

the File>Rename command, which renames all files in the file 
list. 

Auto Select All Runs the auto-selector for all files in the file list. 
Select All Select all the files in the file list. 
Clear List Clears the file list. 
Exclude Unmatched Excludes any files from the file list that are not matched by the 

selector. 
Exclude Unchanged Excludes any files from the file list that will not be changed by 

the current rename command. 
 

Note: the first three commands operate on the selected files in the file list. The other 
commands operate on all files in the file list.  

The selector 

 

The selector sets how the filenames are broken down into parts for renaming. The parts are 
generated by combining adjacent * and ? wild cards into a single wild part, and adjacent text 
characters into a text part. Any # wild cards are turned into a number part. Finally, if any wild 
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or number parts are not followed by a text part, then a blank text part is added so that text can 
be added at those points in the names. 

For example *abc* will be turned into the parts: [empty text], [wild card], ["abc"], [wild 
card], [empty text].  

In order to have full control over the way the selector is broken down into the different parts, 
the / character can also be used to force a break. This is used between wild cards that would 
normally be combined into a single part, which would mean only a single command could be 
applied to that part. For example, the selector ?* will match any filename that has one or more 
characters. However, only one wild part will be generated. If you wanted to apply a command 
to the first character only, it would not be possible. If instead you use the selector ?/* this will 
still match any filename that has one or more characters, but two wild text boxes will be 
generated. The first will be for the first character matched by the ? wild card, and the second 
will be for the rest of the filename matched by the * wild card. This would allow, for 
example, an operation to capitalize the first letter of a filename to be defined. 

The selector will automatically be set to the best match for the files in the file list whenever 
the files in the file list are changed, provided the rename command is not locked.  

The selector also provides access to recently used rename commands. Click on the arrow to 
the right of the selector to open the recent commands drop down list. 

The rename boxes 

 

This area of the window is where the rename information is entered. The filenames are broken 
into parts, each of which has a pair of boxes showing how that part of the filename will be 
changed. The way the filename is broken down into parts is controlled by the selector. 

• Literal text changes - for plain text in the selector  
• Wild text changes - for wild cards (* and ?) in the selector  
• Number changes - for numbers selected using # in the selector  

See “Setting up rename commands” on page 15 for a full description of how to set up rename 
commands. 

Right clicking in any of the rename boxes brings up the context menu for that rename part. 

 
This menu provides the following commands: 
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Clear Sets the part of the filename controlled by the selected rename 
box to be clear 

Reset Sets the part of the filename controlled by the selected rename 
box so that it is unchanged 

Stored Commands list 

The Stored Commands list allows stored commands to be selected. Selecting inside the list 
box will pop up the list of stored commands. Select the one you want, and it will be made the 
current command. 

 

The commands listed in the Stored Commands list are controlled from the stored commands 
panel (see page 27). 

Rename button 

 

The Rename button renames the physical files on the disk. Until this button is pressed, no 
files on the disk will be altered in any way. 

Pressing this button is the same as selecting the File>Rename menu command. 

The files are renamed to the new names shown in the file list. 

As the files are renamed, they are removed from the file list. 
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Allow File Extension Changes switch 

This switch sets whether changes to file extensions are allowed. The file extension is all 
characters after the ‘.’ in the filename. This is usually used to determine what type of data the 
file contains, so you should not normally change this. One consequence of changing a file’s 
extension is that it may no longer be automatically associated with the application that can 
open it. 

If this switch is off, then RenameMan will not allow the file extension to be changed. You can 
still use an extension in the selector, but this will only be used to select files with a particular 
extension. The rename boxes will not include the extension. 

If this switch is on, then you will be able to change the extensions of the files. This does not 
necessarily mean the extension will be changed, since the rename command may not affect 
that part of the filenames. You should only change the extensions of files if you know what 
you are doing. 

Note that by default, Windows Explorer does not show the file extension for known file types. 
Even though Windows Explorer may not show the extension, it still exists in the filenames on 
disk. RenameMan always shows the file extension.  

Store button 

The Store button brings up the stored commands panel. This panel can also be brought up by 
using the stored commands command. 

Locking the rename command 

The current rename command can be locked or unlocked. 

This is indicated by the padlock icon in the top left corner of the rename command section. 

 

Unlocked  
When the rename command is unlocked, the selector will be changed to match 
the files in the file list whenever the file list changes, using the auto-select 
function.  

To unlock the rename command, either click on the padlock button, or select the 
Command>Reset menu command.  

 

Locked  
When the rename command is locked, the selector is not updated when the file 
list changes.  

The rename command is automatically locked whenever a change is made to any 
of the rename boxes. This is because changing the selector usually means the 
current rename command is lost. The rename command is also locked whenever 
a stored command is selected.  

The rename command can be manually locked by clicking on the padlock 
button.  
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Setting up rename commands 

Changing part of the name all files have in common 

This section describes how to rename a set of files that all have a part of their name in 
common, and how to insert text into the filenames. 

First add the files you want to rename to the file list. You then need to enter the pattern in the 
selector that will select all the files that have the common part you want to change. For 
example, to select all filenames that contain DSCF in the name, use the selector *DSCF*. If 
all the files in the file list have the common part you want to change, then the auto-selector 
should have already found this to save having to type the pattern. 

At this stage, you will have several pairs of boxes in the rename command. One of these pairs 
of boxes will have the common part of the name that you want to change. This screen shot 
shows how it will appear when the DSCF has been changed to Fr. 

 
These boxes may also appear like this when empty text boxes are added to allow text to be 
inserted into filenames between wild cards: 

 
If you want to insert text into the name, this can be done by using the text change panel for 
any of the empty boxes. Empty boxes are automatically added to allow text to be inserted at 
any point in the filenames. 

Click in the lower of the pair of boxes, and you will get the text change panel. 

 
 

This panel simply allows new text to be entered that will replace the old text. If the "Leave 
Unchanged" switch is checked, then the original text is left unchanged. If any new text is 
entered, the "Leave Unchanged" switch is automatically unchecked. The reason for having the 
"Leave Unchanged" switch is that although the original text in this part of the name will 
always be the same as the text shown in the "From" field, different filenames may have letters 
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differently in upper case or lower case. If the "Leave Unchanged" switch is checked, the 
original case is preserved, but if it is not checked, files will be renamed to the exact case 
shown in the "To" field. 

Pressing the "Auto-text Wizard" button brings up the auto-text wizard. The auto-text wizard 
allows you to control the settings for the automatically generated text that can be inserted into 
the filenames. See Auto-text wizards on page 20. 

Changing part of the name that is not the same for all files 

This section describes how you can make changes to part of the filenames that is not the same 
for all files. These parts of the filename are those matched by the * or ? wildcards in the 
pattern. The changes that can be made to this part of the filename are: 

• changing the case of letters to upper or lower case  
• find and replace of one substring for another  
• shortening (truncating)  

First add the files you want to rename to the file list. Make sure the pattern in the selector 
contains at least one * or ?. For example, if you want to make all filenames upper case, then 
enter * in the selector. You will get one wild card rename box which can be used to make 
changes to the whole filename. Note that if the allow file extension changes box is not 
checked, then no changes can be made to the filenames’ extensions. 

 
Click in the lower of the pair of boxes with the wild card symbol * in it, and you will get the 
Change Wild panel (see below). 

This panel allows the case of this part of the name to be changed, or the name to be shortened. 
By default, this part of the name is left unchanged. 

You may find at this point that some files have a symbol next to them in the file list. For 
example, this can happen if you have used the "truncate" option to shorten parts of the 
filenames. This indicates that two or more files have been renamed to the same name. You 
will need to correct this before you can rename all the files, by either excluding or 
individually renaming one or more files. 
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Changing the case 
The case of this part of the name can be made upper or lower case by selecting the appropriate 
switch. If it is made upper case, the wild card rename control is shown with a small U like 
this: 

 
If it is made lower case, the wild card rename control is shown with a small L like this: 

 

Find & Replace 
If any text is entered in the "Replace" box, then all occurrences of that text in this part of the 
name are replaced with the text in the "With" box. If no text is entered in the "Replace" box, 
then the "With" box is disabled. 

Although this Find and Replace operation offers similar functionality to simply entering the 
text to be replaced in the selector (surrounded by * wildcards), there are subtle differences. 
Firstly, this Find & Replace operation replaces all occurrences of the text, whereas using the 
selector would only replace the first occurrence. Secondly, this Find & Replace operation 
does a case-sensitive search for text to replace, whereas the selector is case insensitive. 

This Find & Replace operation is particularly useful for single character operations, such as 
removing spaces from filenames, or replacing spaces by underscores. 

Shortening the name 
If the "Truncate" switch is checked, then this part of the name will be truncated to the number 
of characters shown in the "Maximum Length" field. If this part of the name is already shorter 
than this limit for any particular file, then it is left unchanged. When the wild part of the name 
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is being truncated, it is shown by adding the maximum length to the wild card rename control 
like this: 

 

Changing numbers in filenames 

This section describes how to make changes to numbers in filenames. The changes that can be 
made to a number are: 

• Adding or removing leading zeros  
• Adding or subtracting a constant value  

Adding leading zeros to numbers in filenames can be extremely useful, since it means that 
when the files are listed in a browser, they will be listed in numerical order. For example, 
without leading zeros, files named 1 to 12 would be listed in the following order: 1, 10, 11, 
12, 2, 3, 4, 5, 6, 7, 8, 9. Adding leading zeros means that they will be listed in numerical 
order: 01, 02, 03, 04, 05, 06, 07, 08, 09, 10, 11, 12. 

To change numbers in the filenames, first add the files you want to rename to the file list. 
Then make sure the pattern in the selector contains # which is used to match any number. If 
all the files in the current folder contain numbers, then the auto-selector should automatically 
set the pattern to include a # (provided the treat numbers as text option is off). Otherwise, you 
can use *#* in the selector, which will match any filename containing a number. Each # in the 
selector creates a change number box like this: 

 
 

Click in the lower of the number rename pair of boxes, and you will get the Change Number 
panel.  
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This panel allows leading zeros to be added to or removed from the number, and an offset to 
be added to the number. 

Adding leading zeros 
If the "Add" switch is checked, then this part of the name will be changed so that the number 
has at least the number of digits entered in the "digits" field. For example, to change 42 into a 
4 digit number, it is renamed to 0042. If the number already has more digits than that shown, 
it is left unchanged. 

When leading zeros are being added to the number, this is shown in the change number box 
by adding a small "0" in the lower left corner, and the number of digits in the upper left corner 
like this: 

 

Removing leading zeros 
If the "Remove" switch is checked, then any leading zeros in the number will be removed. 
This is shown in the change number box by adding a small "-0" in the lower corner like this: 

 

Adding an offset 
An offset can be added to the number by entering an offset into the "Add offset" field. An 
offset of 0 leaves the number unchanged. The offset can be positive or negative, but if the 
number generated for any filename falls below 0, it will be set to 0. Negative numbers can not 
be generated for filenames. The offset is shown in the change number box in the lower right 
corner like this: 

 

 

Clear number 
If the "Clear number" box is checked, then the number will be removed from the filename. In 
this case, the other controls on the panel are disabled since they have no effect. 
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Auto-text wizards 

Auto-text 

Auto-text is automatically generated text that can be inserted into the filenames. This can be 
one of the following: 

• Numbers  
• File time  
• File size  
• Parent folder name  
• MP3 tag  

Auto-text can be inserted into filenames by using the Change Name panel. Auto-text 
commands are added to the filename by inserting the auto-text command into the filename 
inside < and > characters. For example, the auto-text command to insert a number starting at 0 
and incrementing by 1 for each file is <0>. Since filenames can not contain the characters < or 
>, there is no problem with using these characters to indicate auto-text commands. 

However, you never have to enter auto-text commands directly, since there are five auto-text 
wizards that let you set the auto-text that you want. To bring up these wizards, press the 
Auto-text Wizard button on the Change Name panel.  

When you use an auto-text wizard, you have the choice of replacing the current part of the 
filename with the auto-text, or adding the auto-text to the start or end. This is controlled by 
the pop-up menu at the bottom of the auto-text wizards. This simply controls how the auto-
text command is inserted into the "To" box on the change text panel. Once you have used an 
auto-text wizard to add an auto-text command, you can then make further changes to the text 
in the "To" box, as long as you don’t edit the text between the < and > characters (which is 
the auto-text command itself). 
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Auto-number wizard 

The auto-number wizard is brought up by pressing the Auto-text Wizard button on the 
Change Name panel, and selecting the Auto-number tab. 

 

This auto-text wizard allows you to add numbers to a filename. The start value and step can 
be set. The numbers are set in the filenames in the order that the files are listed in the file list. 
The files in the file list can be sorted either by the name, or by the file size or last-modified 
time. The column headers in the file list show the sort order, since the column that is used for 
sorting will have a small triangle in it. The sort order can also be reversed by clicking on the 
same column header again. The direction of the triangle shows whether the sort order is 
ascending or descending. In order to sort on file size or last-modified time, the appropriate 
column will need to be shown in the file list. These columns can be added or removed using 
the column options panel. 

Setting the start and step values 
The "Start" number is the first number that will be generated. Floating point numbers are not 
supported, and negative values can not be generated for filenames. The "Step" value must also 
be positive. If you want to auto-number the files in the opposite direction, simply reverse the 
sort order by clicking on the sort column header in the file list. 

Restart numbering in each folder checkbox 
This checkbox only has any effect if the file list contains files from more than one folder. If 
this box is checked, then the number sequence will be applied independently to each folder, 
so the same numbers will be generated in each folder. Otherwise, a single number sequence is 
used across all folders, so the number sequence keeps counting up even for files in different 
folders.  

Setting the leading zeros 
To have leading zeros for the generated numbers, simply check the "Leading Zeros Add" 
switch, and enter the number of digits required. Note: if the number already has more digits 
than this, it is left unchanged, it will not be shortened. 
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For more information, see the auto-number command reference on page 40. 

File time auto-text wizard 

The file time wizard is brought up by pressing the Auto-text Wizard button on the Change 
Name panel, and selecting the File Time tab. 

 

This auto-text wizard allows you to add the file last-modified time to a filename, or for digital 
photos in TIFF or JPEG format, the date/time the photo was taken.  

The time can be added in any of the formats available in the pop-up list. For advanced users, 
the text created by the wizard can be hand edited for complete flexibility over the time format.  

For more information, see the file time auto-text command reference on page 40.  
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File size auto-text wizard 

The file size wizard is brought up by pressing the Auto-text Wizard button on the Change 
Name panel, and selecting the File Size tab. 

 

This auto-text wizard allows you to add the file size to a filename. The size can be entered in 
any of the following units: 

• bytes  
• kilobytes (1 KB = 1024 bytes)  
• megabytes (1 MB = 1024 KB)  
• gigabytes (1 GB = 1024 MB)  
• auto  

If auto is selected, then the size will be shown in the largest units possible, i.e. gigabytes if the 
file size is 1GB or greater, or megabytes if 1MB or greater, or kilobytes if 1KB or greater, 
otherwise bytes. In auto mode, the units are shown by adding B if the units are bytes, K for 
kilobytes, M for megabytes or G for gigabytes. In all other modes the size is only shown as a 
number, since there is no ambiguity. If you did want to show the units, it can be added like 
any other text after the auto-text command. 

When any units except bytes is selected, the size will always be rounded up to the next whole 
number. 

For more information, see the file size auto-text command reference on page 41. 

Folder name auto-text wizard 

The folder name wizard is brought up by pressing the Auto-text Wizard button on the Change 
Name panel, and selecting the Folder Name tab. 
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This auto-text wizard allows you to add the parent folder name to a filename. 

For more information, see the folder name auto-text command reference on page 42. 

MP3 tag auto-text wizard 

The MP3 tag wizard is brought up by pressing the Auto-text Wizard button on the Change 
Name panel, and selecting the MP3 tab.  

 

This auto-text wizard allows you to use information from MP3 tags to build up the filename.  

Note: if a file in the file list is not an MP3 file, or if it is an MP3 file but does not contain the 
selected MP3 tag, then the MP3 error icon ( ) will be shown next to that file.  

For more information, see the MP3 auto-text command reference on page 42. 



   RenameMan User Guide 
 

25 

Reusing rename commands 

Storing commands 

RenameMan allows you to store any rename command for re-use later. You can add or 
remove commands at any time by using the stored commands panel. Stored commands are 
automatically saved so that they are available the next time you run RenameMan. 

To use a stored command, simply select it in the stored commands list. This sets the rename 
options (allow file extension changes), the selector, and the rename commands to the state 
they were in when the selected command was stored. You can then either simply press the 
rename button to rename the currently selected files, or modify the rename command before 
renaming the files. 

Using recent rename commands 

Whenever files are renamed, RenameMan adds the current rename command to the list of 
recently used commands. This can be brought up by opening the drop down list on the 
selector. Selecting one of the commands from this list restores it as the current rename 
command.  

If the current rename command is already in the recent commands list, it is brought to the top 
of the list.  

The recent commands list is a time-saving feature which means that even if you don't add a 
rename command to the stored commands, it can still be re-used while it remains in the recent 
commands list.  

The number of recent commands kept can be set using the options panel. This also provides a 
button to clear all recent commands from the list.  

Copy and paste of commands 

The Command>Copy Command and Command>Paste Command menu commands allow 
users to easily transfer rename commands between each other. It also provides an alternative 
way to save commands other than by using stored commands. 

These commands encode a rename command in a plain text format that can be sent by email 
or stored in documents. This text can be simply copied from an email or document (back to 
the Windows clipboard) and then the paste command used to set this as the current rename 
command in RenameMan.  

The text created by the copy command will always start with <<< and end with >>>. This 
must be included in the text on the clipboard for the command to be recognized. In fact, 
surrounding text can also be included and the rename command will still be correctly 
extracted. This means that, for example, if an email contains a single rename command, the 
entire text of the email can be copied to the Windows clipboard and then this paste command 
can be used to find the rename command in the text and set it as the current rename 
command.  

Note that the text generated that encodes a rename command is not intended to be 
understandable or edited by users. 
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Dialogs 

Add Files panel 

This panel is brought up by using the File>Add Files menu command. It replaces files in the 
file list with files that are added from the folder currently selected in the folder browser. This 
panel is provided to give greater control over the files that are added to the file list rather than 
simply adding all files in the selected folder, which is the default action when a folder is 
selected.  

 

The panel allows the files added to be controlled in the following way: 

Adding files from subfolders 

If the "Add files from subfolders" checkbox is checked, then files will be added from the 
selected folder, and also from all subfolders in the selected folder. If the "Limit depth" check 
box is also checked, then only subfolders up to the given depth are searched. A depth of 0 
means the selected folder only, a depth of 1 means the selected folder plus the files in its 
subfolders, and so on. 

Only adding files that match a pattern 

If the "Only include files that match" checkbox is checked, then only files that match the 
given pattern will be added to the file list. For files that do not match, it will be exactly as if 
they had been excluded from the file list. This option is useful to avoid adding too many files 
to the file list, which may make RenameMan run very slowly. For example, if you wanted to 
rename all files on your hard disk that ended in ".tiff" to ".tif", rather than adding all files on 
the hard disk to the file list and then using the selector to select just the ones ending in ".tiff", 
it would be much quicker to only add the files that match "*.tiff" in the first place. 

Only adding files that do not match a pattern 

If the "Exclude files that match" checkbox is checked, then only files that do not match the 
given pattern will be added to the file list. 
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If both the "Only include files that match" and the "Exclude files that match" options are 
selected, then a file must both match the include pattern, and not match the exclude pattern to 
be added to the file list. 

Add Folders panel 

This panel is brought up by using the File>Add Folders menu command. It replaces the 
contents of the file list with subfolders of the folder currently selected in the folder browser. 
This allows folders to be renamed.  

 

The panel allows the folders added to be controlled in the following way: 

Only adding folders that match a pattern 

If the "Only include folders that match" checkbox is checked, then only folders that match the 
given pattern will be added to the file list. This option is useful to avoid adding too many 
folders to the file list, which may make RenameMan run very slowly. 

Only adding folders that do not match a pattern 

If the "Exclude folders that match" checkbox is checked, then only folders that do not match 
the given pattern will be added to the file list. 

If both the "Only include files that match" and the "Exclude files that match" options are 
selected, then a folder name must both match the include pattern, and not match the exclude 
pattern to be added to the file list. 

Note: It is not possible to add folders from more than one parent folder at a time. 

Stored Commands panel 

This panel is brought up using the View>Stored Commands menu command, or by pressing 
the store button. This panel provides control over the stored commands. Commands can be 
re-ordered, added, deleted or renamed. After the desired changes have been made, press the 
OK button. If you change your mind about the changes you have made, pressing Cancel will 
close the panel and lose all the changes that were made. 
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The following actions can be performed using this panel: 

Import stored commands list 

 
The Import Stored Commands button allows a file containing a set of stored commands to be 
loaded. These files can be created using the Export Stored Commands button. Any stored 
commands already in the list are replaced by those loaded from the file. Note that 
RenameMan automatically remembers the current stored commands list so it is not necessary 
to reload the list from a file every time RenameMan is run. 

Export stored commands list 

 
The Export Stored Commands button stores the current list of stored commands to a file. 
Stored commands are stored in a file with a ".cmds" extension.  

Move stored command up/down the list 

 
These commands allow the list of stored commands to be re-ordered. First, select a stored 
command in the list, then press the Move Up or Move Down buttons to move it up or down 
the list. 

Delete stored command 

 
This command allows a stored command to be deleted. Select a stored command in the list, 
and press the Delete button. 

Change stored command name 
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This command allows the name of a stored command to be changed. The name of a stored 
command is what is shown in the stored commands list. Select a stored command in the list, 
then press the Change Name button. This brings up the change command name panel that 
allows you to change the name of the stored command. 

Add stored command 

 
This command allows a new rename command to be added to the stored commands list. The 
rename command added is the one that is currently set up in the rename boxes. The rename 
command must be set up before the Stored Commands panel is brought up, although you do 
not have to rename any files in order to add the current command. 

When the Add Command button is pressed, the add command panel is brought up. Enter the 
name that you want for the new command. This is the name that will be used in the stored 
commands list. 

Add Command panel 

This panel is brought up by pressing the Add button on the stored commands panel, or by 
using the Command>Add To Store menu command. 

 

Enter the name that you want for the new command, and press "OK". The name will be the 
name shown in the stored commands list, so make sure it is descriptive enough that you will 
be able to remember what it does. 

Change Command Name panel 

This panel is brought up by pressing the Name button on the stored commands panel. 

 
Enter the new name that you want for the selected command, and press "OK". 
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General Options panel 

The general options panel is brought up by selecting the View>Options menu command. 

 
This panel allows you to set the following options: 

Recent folders list size 
Each time a folder is selected it is added to the recent folders list, which can be found in the 
Recent Folders submenu of the file menu. This option allows you to change how many folders 
are kept in the recent folders list. Note that when this value is changed, it will only take effect 
the next time you run RenameMan. 

Recent commands list size 
Each time files are renamed by pressing the rename button, the rename command is saved 
automatically in the recent commands list. This list can be accessed from the selector drop 
down list. This option allows you to change how many recent rename commands are kept.  

Column Options panel 

The column options panel is brought up by selecting the View>Options menu command, and 
then pressing the "Columns" tab. 

 
This panel allows you to select which of the optional columns appear in the file list. 
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File Size If this box is checked, then a column showing the size of each 
file in the file list is added. 

Modified Time If this box is checked, then a column showing the last modified 
time of each file is shown in the file list. 

Read-Only 
If this box is checked, then a column showing whether each file 
is read-only is shown in the file list. Read-only files are 
indicated by an R in this column. 

 

These first two of these additional columns can be useful when using the auto-number 
command, since they allow the list to be sort by file size or modified time. 

An alternative way to show or hide these columns is to right click in the column header in the 
file list, and select the column name from the pop-up menu. 

Rename Single File panel 

This panel is brought up by using the File>Rename Single File menu command. 

 

This allows a single file to be quickly renamed. Enter the new name in the "To" field and 
press "OK".  

After the file is renamed, it is excluded from the file list.  

Serial Number panel 

To bring up the Serial Number panel, use the Help>About menu command. This brings up the 
About box. If you are running the trial version of RenameMan, then this panel will have a 
Enter Serial button on it to bring up the Serial Number panel. 
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This panel is used to enter the serial number that you get if you buy RenameMan from the 
web site. 

Note: if you have copied the serial number into the copy buffer (from an email or web page 
for example), you can paste it into this box by using the shortcut CTRL-V, or by right 
clicking in the text box and selecting the "Paste" option.  

The easiest way to buy RenameMan is from the Buy panel. Buying this way guides you 
through process, and automatically saves the serial number and activates it, so you don't have 
to use the Serial Number panel. 
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Menu commands 
 

File menu commands 

The File menu offers the following commands: 

Add Files Brings up the Add Files panel. 
Add Folders Brings up the Add Folders panel. 
Clear List Clears the file list. 
Treat Numbers As 
Text 

When this option is enabled, the auto-selector will not try to find numbers 
in filenames. 

Auto Select Runs the auto-selector for the currently selected files. 
Exclude Excludes the currently selected files from the file list. 
Exclude Unmatched Excludes any files from the file list that are not matched by the selector. 

Exclude Unchanged Excludes any files from the file list that will not be changed by the current 
rename command. 

Rename Single File Renames a single file. 
Rename Renames all the files in the file list. 
Undo Rename Undoes the last rename operation. 
Recent Folders This submenu contains the most recently selected folders. 
Exit Exits RenameMan. 
 

Add Files 
This command brings up the add files panel. This command is available in the File menu, or 
from the folder browser context menu. 

The add files panel provides extra tools for adding files to the file list for renaming.  

Shortcut 

Key: F2 

 

Add Folders 
This command brings up the add folders panel. This command is available in the File menu, 
or from the folder browser context menu. 

The add folders panel allows you to add folder names to the file list for renaming.  

Shortcut 

Key: F3 

 



   RenameMan User Guide 
 

34 

Clear List 
This command removes all files from the file list. This command is available in the File 
menu, or from the file list context menu. 

Shortcut 

Key: ESC 

 

Treat Numbers As Text 
This command affects how the auto-select function works.  

RenameMan has special support for filenames containing numbers, so by default the auto-
select function will try to match numbers using the match any number wildcard (#). When this 
is used, number based commands such as adding or removing leading 0s, or adding an offset 
to the number are available.  

However, in some cases where the numbers in the filenames are not important, it may be 
more useful to treat the numbers just like any other characters.  

Selecting this command toggles the flag to treat numbers as text on and off.  

Shortcut 

Key: ALT, F, N 

 

Auto Select 
This command runs the auto-selector for the selected files. This command is available in the 
File menu, or from the file list context menu. 

If no files are selected, the selector is not changed. 

Shortcut 

Keys: ALT, F, S 

 

Exclude 
Use this command to exclude the selected files from the file list. This command is available in 
the File menu, or from the file list context menu. 

The exclude command provides a way of modifying the list of files that will be renamed. 

To exclude several files in one go, first select several files in the file list. This is done by 
holding down the SHIFT key while clicking on a file to select a range, or holding down the 
CONTROL key while clicking on another file to add files to the selection one by one. Right 
click on the selection and you will get a pop-up menu with the exclude command in it, which 
you can use to exclude all the selected files. 

Shortcut 

Keys: ALT, F, E 
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Exclude Unmatched 
Use this command to exclude files from the file list that are not matched by the selector. Files 
that are not matched by the selector are shown grayed.  

This command is available in the File menu, or from the file list context menu. 

Shortcut 

Keys: ALT, F, M 

 

Exclude Unchanged 
Use this command to exclude files from the file list that will not be changed by the current 
rename command.  

This command is available in the File menu, or from the file list context menu. 

Shortcut 

Keys: ALT, F, C 

 

Rename Single File 
This command brings up the rename file panel, which is used to rename a single file.  

This command can be used to quickly rename just the selected file. This can be useful if you 
find you want to rename just one or two files in a folder in a different way to all the others.  

If this command is grayed out, make sure you have selected the file you want to rename in the 
file list 

If more than one file is selected, then this command will rename just the first selected file. 

Once a file is successfully renamed using this command, it will then be automatically 
removed from the file list. 

Shortcut 

Keys: ALT, F, R 

 

Rename 
This command renames all the files in the file list to the new names shown. This is the same 
as pressing the rename button. 

You can use the Undo Rename command to restore the files to their original names. 

Shortcut 

Key: F5 

 

Undo Rename 
This command renames the files that were renamed by the most recent rename command back 
to their original names. 

Shortcut 

Keys: ALT, F, U 
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Recent Folders 
The Recent Folders submenu contains the most recently selected folders. Each time a folder is 
selected, it is added to the top of the Recent Folders submenu. The number of folders kept in 
the Recent Folders submenu can be controlled using the options panel. 

Selecting a folder from the Recent Folders submenu selects that folder in the folder browser. 

 

Exit 
Use this command to end your RenameMan session. You can also use the Close command on 
the application Control menu.  

Shortcuts 

Mouse: Double-click the application's Control menu button. 

Keys: ALT+F4 

 

Edit menu commands 

The Edit menu offers the following commands: 

Cut Deletes data from the document and moves it to the clipboard. 
Copy Copies data from the document to the clipboard. 
Paste Pastes data from the clipboard into the document. 
 

Cut 
Use this command to remove the selected text from the selector text box and put it on the 
clipboard. This command is unavailable if the selector text box does not have focus. 

Cutting text to the clipboard replaces the contents previously stored there. 

Note: this command is only for cutting text that is selected in the selector text box, it can not 
be used to cut files or folders. 

Shortcut 

Keys: CTRL+X 

 

Copy 
Use this command to copy the text selected in the selector text box onto the clipboard. This 
command is unavailable if selector text box does not have focus. 

Copying text to the clipboard replaces the contents previously stored there. 

Note: this command is only for copying text that is selected in the selector text box, it can not 
be used to copy files or folders. 

Shortcut 

Keys: CTRL+C 
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Paste 
Use this command to insert a copy of the clipboard contents at the insertion point in the 
selector text box. This command is unavailable if the selector text box does not have focus. 

Shortcut 

Keys: CTRL+V 

 

View menu commands 

The View menu offers the following command: 

Options Brings up the Options panel. 
Stored Commands Brings up the Stored Commands panel. 

View Options 
This command brings up the options panel. 

Shortcut 

Keys: ALT, V, O 

 

Stored Commands 
This command brings up the stored commands panel. This is used to manage the stored 
commands. Stored commands can be added, removed, renamed and reordered. 

This command is the same as pressing the store button. 

Shortcut 

Keys: ALT, V, S 

 

Command menu commands 

The Command menu offers the following commands: 

Reset Resets the current rename command. 
Add To Store Adds the current rename command to the stored commands list. 
Copy Command Copies the current rename command to the clipboard in a text format. 

Paste Command 
Pastes a command to the current rename command from the clipboard. 
This should contain a text description of a command previously copied 
using Copy Command. 
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Reset 
This command resets the current rename command. The selector and rename boxes are 
cleared. Note: after selecting this command, any files in the file list will show a rename error 
since they will be being renamed to nothing.  

Shortcut 

Key: ALT, C, R 

 

Add To Store 
Adds the current rename command to the stored commands list.  

This is the same as bringing up the store commands panel and pressing the add stored 
command button.  

Shortcut 

Key: F9 

 

Copy Command 
This command encodes the current rename command into a plain text format and copies this 
to the Windows clipboard. The text is not intended to be understood or edited by users. If the 
same text is used with Paste Command, the command can be restored in RenameMan.  

This command allows users to easily transfer rename commands between each other. It also 
provides an alternative way to save commands other than by using stored commands. Using 
this command allows rename commands to be sent by email or stored in documents. The text 
encoding a rename command can be simply copied from an email or document (back to the 
Windows clipboard) and then Paste Command used to set this as the current rename 
command in RenameMan.  

Shortcut 

Keys: CTRL+SHIFT+C 

 

Paste Command 
This command pastes a command copied with Copy Command into the current rename 
command. This is done by decoding the text on the Windows clipboard to extract the rename 
command data.  

If the Windows clipboard does not contain a rename command, or if the text has been edited 
to make it invalid, an error panel will be shown and the current rename command will not be 
changed.  

The text created by Copy Command will always start with <<< and end with >>>. This must 
be included in the text on the clipboard for the command to be recognized. In fact, 
surrounding text can also be included and the rename command will still be correctly 
extracted. This means that, for example, if an email contains a single rename command, the 
entire text of the email can be copied to the Windows clipboard and then this paste command 
can be used to find the rename command in the text and set it as the current rename 
command.  

Shortcut 

Keys: CTRL+SHIFT+V 
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Help menu commands 

The Help menu offers the following commands, which provide you assistance with this 
application:  

Help Topics Offers you an index to topics on which you can get help. 
What’s this? Provides context sensitive help. 
About Displays the version number of this application. 

Help Topics 
Opens the help window, showing the contents. 

To get context sensitive help on the currently selected object, press F1. 

Shortcut 

Keys: ALT, H, H 

 

Context Help 
Use the Context Help command to obtain help on some portion of RenameMan. When you 
choose the "What's This?" menu command, the mouse pointer will change to an arrow and 
question mark. Then click somewhere in the RenameMan window, such as another menu. The 
Help topic will be shown for the item you clicked. 

Shortcut 

Keys: SHIFT+F1 

 

About 
Use this command to display the copyright notice and version number of your copy of 
RenameMan. 

Shortcut 

Keys: ALT, H, A 
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Auto-text command reference 
 
This section describes the format used for the various auto-text commands. These are used to 
insert automatically generated text into the filename, such as an automatically incrementing 
number, of a file attribute. 

Note: You should not need to enter auto-text commands manually, instead use the appropriate 
auto-text wizard.  

Auto-number command reference 

This command generates a number sequence. 

The format of the auto-number command is:  

<start[,step][:ndigits][f]> 
 

Where: 

start Specifies the number to start counting from 

step [Optional] Specifies the step for each count. If not specified, the step 
will be 1. 

ndigits [Optional] If this is specified, then leading 0s will be added to make the 
number ndigits digits long. 

f 
[Optional] If a suffix f is added, then the count will run independently in 
each folder. This will only have any effect if files from more than one 
folder are being renamed at the same time. 

 

Note: start, step and ndigits cannot be negative. 

Examples: 

<0> 0, 1, 2, 3, 4, ... 
<10,5> 10, 15, 20, 25, 30, ... 
<0:5> 00000, 00001, 00002, 00003, 00004, ... 
<94,4:3> 094, 098, 102, 106, 110, ... 

File time auto-text command reference 

This inserts the time of the file. This can either be the last-modified date/time of the file, or 
for digital photos in TIFF or JPEG format it can be the date/time the photo was taken.  

Note: You should not need to enter auto-text commands manually, instead use the file time 
auto-text wizard. However, you may occasionally want to edit or enter manually this auto-text 
command, since there are date formats that are not available from the wizard.  
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The format of the file time auto-text command is one of:  

<d:date-string> - for last-modified time. This command is available for all files. 

<p:date-string> 
- for digital photo time. Each file being renamed must contain the 
date/time that the digital photo was taken in EXIF format within 
the TIFF or JPEG file. This is the format used by most digital 
cameras.  

 

date-string can contain any of the codes in the following list. Other characters can also be 
inserted in the date string, and these will be passed through. For each code, an example is 
given for how the date Monday July 4th, 2005 2:35pm will appear. 

yyyy Year, with century (2005) 
yy Year, no century (05) 
y Year, no leading zeros, so in practise the same as yyyy (2005) 
mm Month, numeric (07) 
m Month, numeric with no leading zeros (7) 
month Month, text (July) 
mmm Month, three character abbreviation (Jul) 
day Day of the week (Monday) 
ddd Day of the week, three character abbreviation (Mon) 
dd Day of the month (04) 
d Day of the month, no leading zeros (4) 
time Time: hours and minutes as HHMM (1435) 
timehms Time: hours, minutes and seconds as HHMMSS (143500) 
hour Time: hour (14) 
min Time: minute (35) 
sec Time: second (00) 

File size auto-text command reference 

This command inserts the size of the file. 

Note: You should not need to enter auto-text commands manually, instead use the file size 
auto-text wizard. However, this wizard does not support the option to specify the number of 
digits, so you may want to manually edit the command to add this.  

The format of the file size auto-text command is:  

<s[:[ndigits][units]]> 
 

Where units is one of: 

b Bytes 
k Kilobytes (1024 bytes) 
m Megabytes (1024 kilobytes) 
g Gigabytes (1024 megabytes) 
a Automatically selects the highest unit that the size is 1 or more of. 
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If units is not specified, the size is shown in bytes. 

If ndigits is specified, the size is shown with leading zeros added to pad the value to ndigits 
digits.  

The size is shown as a numeric value only unless the a format is selected. In this case, since 
the units vary, the suffix B, K, M, or G, is added to indicate the units shown.  

For units other than bytes, the value shown is always rounded up. 

Examples 

These examples show how a file of size 12,345 bytes would be shown.  

<s> 12345 Bytes 
<s:k> 13 Kilobytes (rounded up) 
<s:8> 00012345 Bytes, with leading zeros to make 8 digit number 
<s:4k> 0013 Kilobytes, with leading zeros to make 4 digit number 
<s:a> 13K Automatically selects kilobytes 

Folder name auto-text command reference 

This command inserts the name of the folder in which the file being renamed exists. 

The format of the folder name auto-text command is:  

<f> 

MP3 auto-text command reference 

This command inserts information read from ID3 tags in an MP3 file. If this command is used 
with files that are not MP3 files, or with MP3 files that do not contain the requested ID3 tags, 
then an error will be shown for those files.  

The format of the MP3 auto-text command is:  

<mp3:tag> 
 

Where tag is one of: 

trackno 
title 
subtitle 
artist 
album 
composer 
conductor 

 

A single MP3 auto-text command can only enter one MP3 tag. Typically you will want to 
rename a file using several MP3 tags. This is done by entering more than one MP3 auto-text 
command, for example:  

<mp3:trackno> - <mp3:title>
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License 

END-USER LICENSE AGREEMENT FOR RENAMEMAN 

1. Introduction 
This License applies to the RenameMan v3.1 software and its accompanying files, data and 
materials ("RenameMan"). You should carefully read the following terms and conditions 
before using, installing, copying, or distributing this software. Unless you have a different 
license agreement signed by ExtraBit Software. ("ExtraBit"), your use, installation, copying, 
or distribution of RenameMan indicates your acceptance of this agreement ("License"). The 
terms and conditions of this License describe the permitted use and user(s) of the evaluation 
version of RenameMan, and of each Licensed Copy of RenameMan. For the purposes of this 
License, if you have a valid single-user license, you have the right to use a single "Licensed 
Copy" of RenameMan; if you or your organization has/have a valid multi-user license, then 
you or your organization has/have the right to use up to a number of "Licensed Copies" of 
RenameMan equal to the number of copies indicated in the documents issued by ExtraBit 
when granting the license.  

2. Scope of License 

2.1. Evaluation 
This is not free software. Subject to the terms below, you are hereby licensed by ExtraBit to 
use one copy of RenameMan, on one (1) computer or workstation, for evaluation purposes 
without charge for a period of 30 days. If you use this software after the 30-day evaluation 
period, a license fee is required. Use of RenameMan after the 30-day evaluation period 
without payment of the license fee is a breach of this License and a violation of international 
copyright laws.  

Subject to all of the terms of this License, you may, without making any payment to ExtraBit:  

a) give exact copies of the evaluation version of RenameMan personally to anyone; 
b) distribute exact copies of the evaluation version of RenameMan, if done exclusively 
through electronic channels; and 
c) make as many exact copies of this evaluation version of RenameMan as you wish, for 
purposes of distribution as described in (a) and (b) above. 

2.2. Licensed Copy 
Each Licensed Copy of RenameMan may be used on a single workstation.  

Each Licensed Copy may be accessed through a network, provided that you have purchased 
rights to use a Licensed Copy for each workstation that will access RenameMan through the 
network. For instance, if 8 different workstations will access RenameMan on the network, 
you must purchase rights to use 8 Licensed Copies of RenameMan, regardless of whether the 
8 workstations will access RenameMan at different times, or concurrently.  

All rights of any kind in RenameMan which are not expressly granted in this License are 
entirely and exclusively reserved to and by ExtraBit. RenameMan is protected by copyright 
laws and other applicable laws and treaties. You may use, install and distribute RenameMan 
solely as expressly provided in this License. You may not rent, lease, loan, sublicense, 
modify, translate, reverse engineer, decompile, disassemble, or create derivative works based 
on, RenameMan, nor permit anyone else to do so. You may not make access to RenameMan 
available to others in connection with a service bureau, application service provider, or 
similar business, nor permit anyone else to do so.  
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3. Warranty Disclaimers and Liability Limitations 
RENAMEMAN, AND ANY AND ALL ACCOMPANYING SOFTWARE, FILES, DATA 
AND MATERIALS, ARE DISTRIBUTED AND PROVIDED "AS IS" AND WITH NO 
WARRANTIES OF ANY KIND, WHETHER EXPRESS OR IMPLIED, INCLUDING, 
WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE. EXTRABIT DOES NOT WARRANT, GUARANTEE, 
OR MAKE ANY REPRESENTATIONS REGARDING THE USE OF, OR THE RESULTS 
OF THE USE OF, RENAMEMAN. EXTRABIT DOES NOT WARRANT THAT THE 
OPERATION OF RENAMEMAN WILL BE UNINTERRUPTED OR ERROR-FREE.  

EXCEPT TO THE EXTENT EXPRESSLY PROHIBITED BY APPLICABLE STATUTES, 
EXTRABIT SHALL NOT BE LIABLE FOR ANY DAMAGE OR FINANCIAL LOSS 
ARISING OUT OF THE USE OF, OR INABILITY TO USE, RENAMEMAN. ANY 
LIABILITY OF EXTRABIT WILL BE LIMITED EXCLUSIVELY TO REFUND OF THE 
LICENSE FEE PAID TO EXTRABIT. EXCEPT TO THE EXTENT EXPRESSLY 
PROHIBITED BY APPLICABLE STATUTES, IN NO EVENT SHALL EXTRABIT BE 
LIABLE FOR ANY INDIRECT, INCIDENTAL, CONSEQUENTIAL, SPECIAL, OR 
PUNITIVE DAMAGES WHATSOEVER RELATING TO THE USE OF RENAMEMAN, 
OR TO YOUR RELATIONSHIP WITH EXTRABIT, (INCLUDING, WITHOUT 
LIMITATION, LOSS OF DATA OR INFORMATION, LOSS OF PROFIT, REVENUE, 
BUSINESS OPPORTUNITY OR BUSINESS ADVANTAGE, OR BUSINESS 
INTERRUPTION), WHETHER BASED UPON A CLAIM OR ACTION OF CONTRACT, 
WARRANTY, NEGLIGENCE, STRICT LIABILITY, CONTRIBUTION, INDEMNITY, 
OR ANY OTHER LEGAL THEORY OR CAUSE OF ACTION, EVEN IF ADVISED OF 
THE POSSIBILITY OF SUCH DAMAGES.  

IN ADDITION, IN NO EVENT DOES EXTRABIT AUTHORIZE YOU OR ANYONE 
ELSE TO USE RENAMEMAN IN APPLICATIONS OR SYSTEMS WHERE 
RENAMEMAN'S FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO 
RESULT IN A SIGNIFICANT PHYSICAL INJURY, OR IN LOSS OF PROPERTY, OR IN 
LOSS OF LIFE. ANY SUCH USE IS ENTIRELY AT YOUR OWN RISK, AND YOU 
AGREE TO HOLD EXTRABIT HARMLESS FROM ANY AND ALL CLAIMS OR 
LOSSES RELATING TO SUCH UNAUTHORIZED USE.  

4. General 
This License is the complete statement of the agreement between the parties on the subject 
matter, and merges and supersedes all other or prior understandings, purchase orders, 
agreements, and arrangements. This License shall be governed by the laws of England. There 
are no third-party beneficiaries of any promises, obligations, or representations made by 
ExtraBit herein. Any waiver by ExtraBit of any violation of this License by you shall not 
constitute, nor contribute to, a waiver by ExtraBit of any other or future violation by you of 
the same provision, or any other provision, of this License. If any part of this License or the 
application thereof to any person or circumstance is for any reason held invalid or 
unenforceable, it shall be deemed severable, and the validity of the remainder of this License, 
or the applications of such provision to other persons or circumstances, shall not be affected 
thereby.  

RenameMan Copyright © 1998-2005 by ExtraBit Software. All rights reserved. 

 


